Archives

You are currently viewing archive for May 2009

[@上海] 30 May 2009 はてなブックマーク - 田子坊 Twitterでつぶやく

田子坊

久々の写真アップ。
5月頭に泰康路の田子坊に行ってきました。
小さなカフェやお土産屋が小区路地に濫立しており、観光客向けではありますが、レトロでごちゃごちゃした上海気分を味わうのであれば、新天地や預園よりもずっとおすすめです。

[メモ] 20 May 2009 はてなブックマーク - Ubuntu8.04LTSへ最新のOpenOffice.org3.1を入れる方法 Twitterでつぶやく

Ubuntu8.04LTSへ最新のOpenOffice.org3.1を入れる方法

Ubuntu8.04LTSへ最新のOpenOffice.org3.1を入れる方法についてメモ、8.04に標準で入ってるのは2.4。
3.1の方が見栄えも良いしWriterのノート機能が向上してるので、やっぱりそっちが使いたいなー。



参考は以下の2サイト:
Ubuntu日本語フォーラム / [解決済み]OpenOffice.org 3.0のインストールの仕方
https://forums.ubuntulinux.jp/viewtopic.php?pid=20280#p20280
Ubuntu 7.10のOpenOffice.orgのフォントにアンチエイリアスを適用する - Sickly Life はてな版
http://d.hatena.ne.jp/itiri/20080201/1201873966

---------------------------------

1, 現在のOpenOffice.orgを抜いておく

$ sudo apt-get remove openoffice.org-core

2, OpenOffice.org公式サイトから(32bit/64bitは自分の環境に合わせて)debパッケージを落としてくる。

http://ja.openoffice.org/download/3.1.0/

→ 落としたら展開して、そのディレクトリに移動

$ tar xvz OOo_3.1.0_LinuxIntel_install_ja_deb.tar.gz
$ cd OOO310_m11_native_packed-4_ja.9399
$ ls
DEBS licenses readmes update
$ cd DEBS
$ ls
desktop-integration
ooobasis3.1-base_3.1.0-11_i386.deb
(たくさんあるので省略)
openoffice.org3_3.1.0-11_i386.deb

3, 本体インストール開始

$ sudo dpkg -i o*.deb

4, desktop-integrationのインストール(メニューとかの登録)

$ cd desktop-integration
$ sudo dpkg -i o*.deb

5, /usr/bin/sofficeにアンチエイリアスの設定を追加

→ デフォルトだとメニューとかのアンチエイリアスがOFFになってる。


$ sudo vi /usr/bin/soffice

そして
# export STAR_PROFILE_LOCKING_DISABLED

の下あたりに下記の環境変数を追加する。

export SAL_EMBEDDED_BITMAP_PRIORITY=0

以上でOOo3.1のセットアップが完了。

[メモ] 17 May 2009 はてなブックマーク - NetBeans6.5をUbuntu8.04.2で動かすとキーロックされる件 Twitterでつぶやく

NetBeans6.5をUbuntu8.04.2で動かすとキーロックされる件

Eclipseでscim-bridge系統の問題があったので、最初はSCIMを疑って下記を発見。
そんな悲しい目をしないで » Blog Archive » Ubuntu + NetBeans で日本語入力の不具合
http://www.gabuchan.net/blog/archives/35

でもSCIMのバージョンを調べると1.4.7-3ubuntu8だったので該当せず。で、下記を探し出す。

Ubuntu日本語フォーラム / JAVAアプリのキーボードが効かなくなる件
https://forums.ubuntulinux.jp/viewtopic.php?id=4806

Nabble - NetBeans - Japanese Users - NetBeans6.5でキーボードが効かなくなる件
http://www.nabble.com/NetBeans6.5%E3%81%A7%E3%82%AD%E3%83%BC%E3%83%9C%E3%83%BC%E3%83%89%E3%81%8C%E5%8A%B9%E3%81%8B%E3%81%AA%E3%81%8F%E3%81%AA%E3%82%8B%E4%BB%B6-td23329524.html

結論から言うと、Linux版Javaのバグらしい。
Bug ID: 6506617 Keyboard-lock in swing program on Linux box
http://bugs.sun.com/bugdatabase/view_bug.do?bug_id=6506617

しかも、悲しいことに2006/12/20に上がって以来、丸2年FIXの兆しはない。以下コメント紹介。

おそらく激しく苛ついてるvj_robaさんのコメント:

いったい、いつ直すんだ?
このせいで俺のソフトはLinuxで動かねえ。
マジ頼むよ。
Sunの連中は、このバグのせいでSwing/AWTのアプリが
非英語圏のLinux環境じゃ使えないってわかってんのか?

で、環境変数AWT_TOOLKITを設定すると云々の件については、
IanLewisさんのコメント:

AWT_TOOLKIT=MToolkit の設定は意味ないっぽいね、
つーか前よりひどくなった。ESCでWindow閉じると再現する。
AWT_TOOLKIT=XToolkit の設定は少し良くなったけど、
Windowスイッチするとやっぱり発生するね。

#ちなみに、ウチの環境(Ubuntu 8.04.2 64bit/1.6.0_07-b06)ではXToolkit設定しても有意な差は見られなかった。

Ubuntu日本語フォーラムに書いてあったけど、マウスを右クリック、左クリックすれば解決する。

[Linux] 03 May 2009 はてなブックマーク - Ouch! Ubuntu 7.10(Gusty) already reached end-of-life. Twitterでつぶやく

Ouch! Ubuntu 7.10(Gusty) already reached end-of-life.

end-of-life
新型インフルエンザがパンデミックしそうなGW真っ最中の今日この頃、皆さん以下がお過ごしでしょうか?
私は、9.04へいつ乗り換えようかなー。でもLTSじゃないし不安だなぁなんて考えたりしながらGW中なのに仕事をやっております。
そんなときに出くわした出来事を一つ・・・。


それは、開発サーバに足りないツールを入れようと、いつもの用に鼻歌まじりでapt-getを実行したときに発生しました。

http://jp.archive.ubuntu.com/ubuntu/pool/universe
/l/***/******_i386.deb の取得に失敗しました
404 Not Found
E: いくつかのアーカイブが取得できません。
apt-get update を実行するか --fix-missing
オプションを付けて試してみてください。

あ、あれ?

sudo apt-get update
-----略------
http://security.ubuntu.com/ubuntu/dists
/gutsy-security/multiverse/source/Sources.gz
の取得に失敗しました
404 Not Found
パッケージリストを読み込んでいます... 完了
E: いくつかのインデックスファイルのダウンロードに
失敗しました。これらは無視されるか、古いものが
代わりに使われます。

おおおおおおおおぉ???
なぜだぁぁ!aptリポジトリサーバにつながらない。
サーバが落ちてるのかと思って直接http://jp.archive.ubuntu.com/ubuntu/dists/を見てみる。
おっおおおおっ!!!!Gustyが消えてる。ない!ないぞ( ゚д゚)

あ・・・・・ひょっとして、あれか、end-of-lifeか???
しょうがない、アップグレードするか・・・・。
・・・・・・・・。
・・・・
・・
って、リポジトリがねーのにどうやってバージョンアップするんだあぁぁ!
詳しくはこちらに書いておきました。
http://www.makino-style.org/ura/index.php?UpgradeFromEolUbuntu

#いや、真面目に少し焦った。みんなもEOLとかEOSとか言われるものには気をつけて

[技術一般] 01 May 2009 はてなブックマーク - NetBeansのPHP環境が何やら凄いことに・・・ Twitterでつぶやく

NetBeansのPHP環境が何やら凄いことに・・・

ご無沙汰してます。最近はTumblrとかTwitterとかやって、CDCの新型インフル情報とか購読してました。あとなんかやたらとドタバタしてました。

で、ですよ。表題の件なわけですが、NetBeans6.5.1に超ビックリです。元々Swing作るならNBの方が良かったわけですが、PHPやRubyの開発環境としても完成度がめちゃめちゃ上がってる・・・・。

サクッと触っただけですが、下記の印象です。(あれ?なんかいずれも昔のEclipseの特徴だった様な気がするなw)
・ 起動速度が速い
・ 動作が速い
・ コード補完の頭が良い
・ EclipseキーバインドのEclipse再現性が格段に向上
・ PDTよりは安定してる

現在、現場ではEclipsePDTを利用してるわけですが、(Javaはともかく)PHPの環境については明らかにEclipsePDTを凌駕している様なので、真面目に乗り換えを検討しようと思っています。

#総領事館に電話してパンデミックして感染したらどうしたらいいでしょう?って電話で聞いたら普通に現地の病院行けと言われたw
«Prev || 1 || Next»